IT Consultant Everyday Notes

Just some problems/solutions storage

SCCM: Client cannot get Policies automatically; site mode is “Unknown”

In some situations (list for SCCM 2007 is available in this article) you may found an SCCM client cannot get Policy from the server even though it is assign to the site and can see the server (site mode is displayed as “unknown” though on Client side).

Both SCCM 2007 and SCCM 2012 (RTM) is affected. The issue is promised to be fixed for SCCM 2012 with SP1 (available now).

The root cause is a Client Provisioning mode. To detect if the client is in this mode you can check:

32bit Windows OS
HKLM\SOFTWARE\Microsoft\CCM\CcmExec!ProvisioningMode

64bit client Windows OS
HKLM\SOFTWARE\Wow6432Node\Microsoft\CCM\CcmExec!ProvisioningMode

Also, checking the Mobileclient.tcf file in the ccmsetup directory of a fully built machine shows SMSPROVISIONINGMODE=1 in the client install section – on a healthy client this should be
SMSPROVISIONINGMODE=0

A fixing script for SCCM 2012 is provided in that article

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: