IT Consultant Everyday Notes

Just some problems/solutions storage

SCCM 2012 R2 SP1: Boot Image issue

I recently upgraded my SCCM 2012 R2 infrastructure to SP1.

As the first step I uninstall ADK for Windows 8.1 and installed ADK for Windows 10. This is not a requirement, but I found it is much easier to replace ADK during SCCM upgrade than change it later.

I followed this guide for upgrade.

Upgrade passed smoothly, but I noted 64-bit boot image was not upgraded and still showed an old (Windows 8.1) version. I tried to update it from SCCM console, but that attempt failed.

So, I found this article recommending to set exceptions in Antivirus for c:\windows\temp\bootimage folder and <ConfigMgr Instalation folder>\osd\boot folder. After that I could create a new image for 64-bit platform, but still could not fix the default one.

Kent Agerlund recommends to re-copy winpe.wim  from ADK to replace both boot.wim and boot.<PakageID>.wim files and after that RELOAD the proble boot image. I did it and found I am missing a bunch of tabs when open Properties of a boot image! including one with reload button.

Fortunately I found another article describing how to reload the image using PowerShell. Thank you Justin, you wrote your script just in time!

Here is Justin’s script (be sure you replace site code and Package ID):

# ################# DISCLAIMER
# Microsoft provides script, macro, and other code examples for illustration only, without warranty either expressed or implied, including but not
# limited to the implied warranties of merchantability and/or fitness for a particular purpose. This script is provided ‘as is’ and Microsoft does not
# guarantee that the following script, macro, or code can be used in all situations.

# Replace line 9 with your SiteCode
# Replace line 10 with the boot image PackageID to Reload

$SiteCode = “PR1”
$BootImage = Get-WmiObject -Namespace “root\SMS\site_$($SiteCode)” -Class SMS_BootImagePackage -Filter “PackageID = ‘PR100003′” -ErrorAction Stop
$BootImage.ReloadImageProperties()

 

I also need to set Exectution policy to allow the script to be ran:

Set-ExecutionPolicy -Scope Process -ExecutionPolicy Bypass

As soon as the script finished necessary tabs reappeared in SCCM console right OS version was indicated for the boot image and I could distribute the image to DPs successfully.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: