IT Consultant Everyday Notes

Just some problems/solutions storage

Category Archives: UEFI

SCCM: Cannot install Windows 7 x64 to a UEFI based machine using USB boot media

A Customer asked me to help with SCCM OSD.

He gave me a Dell E7440 (my HP8570w shows the same symptoms) as a test machine and asked to configure an SCCM boot media as a bare metal deployment option. The machine supports UEFI (as almost all modern laptop now), so I went to BIOS and put it to Legacy mode to boot from HDD. This is recommended by Microsoft Core team: http://blogs.technet.com/b/askcore/archive/2011/05/31/installing-windows-7-on-uefi-based-computer.aspx

The problem was to boot from USB though – I tried F12 – Legacy – USB Device and got an error “Selected Boot Device failed. Press any key to reboot the system

I tried to boot UEFI – USB Device. It started and pass all way to the first boot from HDD after imaging. And at that point it failed with “Invalid Partition Table’’ error. And that makes some sense since SCCM partitioned the drive for UEFI, and we are trying to boot in Legacy. Switching to UEFI (according Microsoft Windows 7 x64 should support it) did not help – I’ve got “No bootable devices found – Press F1 to retry boot. Press F2 for setup utility

Still keeping some hope to Microsoft statement I set up UEFI – Hard Drive as bootable device and BIOS and tried to image the machine again. At this point image was deployed, but the SCCM Task Sequence failed with nice:

Bcdboot failed! bcdboot.exe C:\WINDOWS /l en-US failed (15299)
stdout:
Failure when attempting to copy boot files
.”

I found a post from Daniel in this thread https://social.technet.microsoft.com/Forums/en-US/9cd54ce3-e5aa-42df-a51b-cf8fc644843f/sccm-usb-boot-always-booting-in-uefi-osd-always-failing?forum=configmanagerosd where he reasonably mentioned the problem can be in the fact we cannot boot SCCM boot media in Legacy mode. So to fix the SCCM boot media I:

1. Created a WinPE media using Win10 ADK (I use SCCM 2012 R2 SP1, so ADK matches)

2. Tried to boot from it and verified the media CAN boot in UEFI-Legacy on the problem machine

3. Copied the following files and folders from SCCM boot media to the newly created WinPE media to ”convert” it to SCCM boot media Smile

image

4. After that I boot from the new media on the Dell Machine in UEFI-Legacy mode. It successfully booted, imaged itself and started from the new image.